设为首页 今天是: 2020-10-24    "联合国日"  联合国正式成立而确定的节日

菏泽盛达网维

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 网吧 工具 系统
查看: 383|回复: 0

[原创] 客户机随机设置壁纸

[复制链接]

2

主题

4

帖子

0

精华

级别:管理员

http://

人气
0
精华
0
金币
50
经验
72
最后登录
2020-9-9
发表于 2019-11-2 18:29:03 | 显示全部楼层 |阅读模式
.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 bmp文件, 文本型
.局部变量 jpg文件, 文本型
.局部变量 png文件, 文本型
.局部变量 指定壁纸, 文本型
.局部变量 命令行, 文本型, , "0"

取命令行 (命令行)
.' 如果真 (命令行 [1] ≠ “-hzsdwl.net.cn”)
    ' 信息框 (“Parameter error!!”, 0, , )
    ' 结束 ()
.如果真结束
.' 如果真 (文件_是否存在 (“C:\NBMSClient\BarClientStartInit.exe”) = 假)
    ' 结束 ()
.如果真结束

bmp文件 = 寻找文件 (取运行目录 () + “\” + “*.bmp”, )
jpg文件 = 寻找文件 (取运行目录 () + “\” + “*.jpg”, )
png文件 = 寻找文件 (取运行目录 () + “\” + “*.png”, )
指定壁纸 = 读配置项 (取运行目录 () + “\DskCfg.ini”, “Config”, “Only”, “desk.bmp”)

.如果真 (文件是否存在 (取运行目录 () + “\” + 指定壁纸) = 真)
    系统_置桌面背景 (取运行目录 () + “\” + 指定壁纸)
    结束 ()
.如果真结束
.判断循环首 (bmp文件 ≠ “”)
    列表框1.加入项目 (bmp文件, )
    bmp文件 = 寻找文件 (, )
.判断循环尾 ()
.判断循环首 (jpg文件 ≠ “”)
    列表框1.加入项目 (jpg文件, )
    jpg文件 = 寻找文件 (, )
.判断循环尾 ()
.判断循环首 (png文件 ≠ “”)
    列表框1.加入项目 (png文件, )
    png文件 = 寻找文件 (, )
.判断循环尾 ()
置随机数种子 ()
编辑框1.内容 = 到文本 (取随机数 (0, 列表框1.取项目数 () - 1))  ' 文件个数来控制随机数上限
列表框1.现行选中项 = 到数值 (编辑框1.内容)
编辑框2.内容 = 列表框1.取项目文本 (到数值 (编辑框1.内容))  ' 编辑框1.内容决定列表框索引文本
系统_置桌面背景 (取运行目录 () + “\” + 编辑框2.内容)  ' 可以为:bmp,jpg,png格式
结束 ()
看的懂得,自己去写。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
冰冻三尺,非一日之寒
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|意见反馈|eMail|盛达网维BBS ( 鲁ICP备19047145号-1 ) |>鲁公网安备37170202665976号

GMT+8, 2020-10-24 21:56 , Processed in 1.397816 second(s), 34 queries , Gzip On.

Powered by Discuz! X3.4

Copyright © 2019-2020,hzsdwl.net.cn

快速回复 返回顶部 返回列表